Elastix: Outbound calling issue



  • @scottalanmiller said:

    Based on your screenshots, there was no reboot. Who told you that they rebooted?

    Reboot would have been before 14:00 EDT yesterday



  • @g.jacobse said:

    Reboot would have been before 14:00 EDT yesterday

    Yes, more than two days ago is the last reboot. It says right on the screen that you showed.



  • uptime
     12:28:49 up 2 days, 22:19,  1 user,  load average: 0.00, 0.00, 0.00
    
    

    I may have been incorrectly informed as such then. I will have to validate that statement.



  • I think it is safe to stop looking at the FreePBX capacity screen and the SAR reports. There is no reason to believe that there is a capacity issue and the FreePBX screen shows wrong information and should never be used for this type of diagnoses anyway. SAR shows no issues with capacity even when there is a problem. Continuing to look at them is just distracting from diagnosis at this point.

    There isn't much to work with, unless the logs show something, the best option is to look at the system at a time during which it has failed.



  • @g.jacobse said:

    uptime
     12:28:49 up 2 days, 22:19,  1 user,  load average: 0.00, 0.00, 0.00
    
    

    I may have been incorrectly informed as such then. I will have to validate that statement.

    Well if someone was telling you that it was rebooted because the DC rebooted, there is bad information guaranteed since "because" makes no sense in that case.



  • I have to admit that some assumptions were made on my part. These assumptions are incorrect. the VM host may have been rebooted but that doesn't seem (as shown) that it affected the VM.

    This is most likely a case of sitting to close to the screen and not seeing the larger picture of how VMs work.



  • We've been through the /var/log/messages log and there is nothing in there to say that anything was amiss. This doesn't mean that nothing was logged but it does suggest that issues are in Asterisk or the trunk and not within the OS.



  • You should scour the Asterisk log from the time period when the outbound calls failed to see if there is something anomalous that happened around that time.



  • What is the call volume? I've read reports of Vitelity doing some strange things when there is a lot of calling. This seems to be linked to the trunk somehow and the best way to diagnose that is to dig into the Asterisk logs and see if there are any rejection messages related to the trunk.



  • @coliver said:

    What is the call volume? I've read reports of Vitelity doing some strange things when there is a lot of calling. This seems to be linked to the trunk somehow and the best way to diagnose that is to dig into the Asterisk logs and see if there are any rejection messages related to the trunk.

    Weekend call volume is nil - during the week, I've never checked.



  • @g.jacobse said:

    @coliver said:

    What is the call volume? I've read reports of Vitelity doing some strange things when there is a lot of calling. This seems to be linked to the trunk somehow and the best way to diagnose that is to dig into the Asterisk logs and see if there are any rejection messages related to the trunk.

    Weekend call volume is nil - during the week, I've never checked.

    Was there an issue this morning?



  • @coliver said:

    @g.jacobse said:

    @coliver said:

    What is the call volume? I've read reports of Vitelity doing some strange things when there is a lot of calling. This seems to be linked to the trunk somehow and the best way to diagnose that is to dig into the Asterisk logs and see if there are any rejection messages related to the trunk.

    Weekend call volume is nil - during the week, I've never checked.

    Was there an issue this morning?

    Thus far, no comments have been made. I just checked the GUI, only 1 call being shown. CPU usage shows less than 5 and memory usage is below 350.

    While the GUI show memory usage jumped from about 180 to over 300 around 12:30am, CPU usage at that time was steady..

    No reports from the site as of yet.



  • Any additional problems?



  • @Reid-Cooper said:

    Any additional problems?

    Unknown. this topic was put on hold while I dealt with a client in Detroit. I have just turned on my desktop having been home 10 minutes. I am in the process of catching up with tasks and items from the last 28 hours.



  • Sounds like.... fun?