Exchange 2013 Max attachement size problems



  • So setting up your max attachment sizes in Exchange is pretty straight forward. Guides like this one give you the PowerShell or GUI ways to handle it.

    But there is a problem that all of these guides miss. There is a single IIS setting that is not updated when you run those commands. Thanks Microsoft......

    This was found to be an issue when a user attempted to forward a large PDF price book. It would just sit in his outbox on his iPhone. The iPhone was set up using the "Exchange" option which uses ActiveSync last I knew. Which is a web connection. Thus IIS settings. Thus web.config.

    I finally found it on this site: https://emg.johnshopkins.edu/?p=1026
    I did not bother to run his script, but I checked each of the pieces he mentioned. Only one setting was not already set correctly.

    In the web.config file for web proxy, it was still set to the default of 10240

    In this file: %ExchangeInstallPath%FrontEnd\HttpProxy\Sync\web.config, find the setting maxRequestLength and update it to match what you set elsewhere.

    09cfa886-6491-4374-a42f-a7d513a649f6-image.png

    You can look at one of the other files to see the exact matching format if needed, such as the Sync service.
    %ExchangeInstallPath%ClientAccess\Sync\web.config – maxRequestLength=”10240″ kilobytes