Second Hostname Not Loading on Apache Virtual Host



  • Site 1:

    *<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

        ServerAdmin webmaster@localhost
        ServerName thanksaj.com
        ServerAlias www.thanksaj.com
        DocumentRoot /var/www/thanksaj.com
    
        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn
    
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    
        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
    

    </VirtualHost>*



  • Site 1 works btw.



  • Site 2:

    *<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

        ServerAdmin builtbyart@gmail.com
        DocumentRoot /var/www/builtbyart.com
        ServerName builtbyart.com
        ServerAlias www.builtbyart.com
    
        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn
    
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    
        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
    

    </VirtualHost>*

    Site 2 does not work.



  • If site 1 is also your default document root, that is why it is working, not because the virtual host is correct.



  • <VirtualHost *:80>

    That is the first line but the doing it in italics screwed it up.



  • They each have a different document root. Each is in the appropriate website folder in /var/www



  • @ajstringham said:

    <VirtualHost *:80>

    That is the first line but the doing it in italics screwed it up.

    I use notepad++ to tab out an entire section i want to paste here then the nobebb detects it as code.



  • @JaredBusch said:

    @ajstringham said:

    <VirtualHost *:80>

    That is the first line but the doing it in italics screwed it up.

    I use notepad++ to tab out an entire section i want to paste here then the nobebb detects it as code.

    Yeah, I didn't realize it did that.



  • @ajstringham my CentOS6.5 webserver has apache 2.2 ithink and when i setup this Centos7 server it is 2.4. I had to add the directory element to my existing virtual host info that i copy/pasted over to the new server.

    		<Directory />
    			Require all granted
    			Options Indexes FollowSymLinks Includes ExecCGI
    			AllowOverride All
    			Order allow,deny
    			Allow from all
    		</Directory>


  • @JaredBusch said:

    @ajstringham my CentOS6.5 webserver has apache 2.2 ithink and when i setup this Centos7 server it is 2.4. I had to add the directory element to my existing virtual host info that i copy/pasted over to the new server.

      	<Directory />
      		Require all granted
      		Options Indexes FollowSymLinks Includes ExecCGI
      		AllowOverride All
      		Order allow,deny
      		Allow from all
      	</Directory>
    

    It's all one server. Those settings are in a different Apache file than the virtual-hosts file.



  • I have 3 files in my /etc/apache2/sites-enabled folder. 000-default.conf, builtbyart.com.conf, and thanksaj.com.conf. The default one has to be there. However, the actual virtual host is brought online when you run:

    a2ensite builtbyart.com
    a2ensite thanskaj.com

    The site name must correspond to a .conf. So if I'm bringing thanksaj.com online, the file has to be thanksaj.com.conf.



  • What I can't figure out is why ThanksAJ.com DOES work but BuiltByArt.com DOES NOT. They are configured exactly the same.



  • Well I cannot help you as my webserver is a simple standard CentOS box with a clean apache install. All the settings are in /etc/httpd/conf/httpd.conf



  • @JaredBusch said:

    Well I cannot help you as my webserver is a simple standard CentOS box with a clean apache install. All the settings are in /etc/httpd/conf/httpd.conf

    Yeah, the RPM-based system vs a Debian-based system.



  • @ajstringham does not explain why apache config files are different. one would think that would work the same because it is apache not the OS.



  • I have even tried redoing Wordpress.

    EDIT: I just checked and had forgotten to redo Wordpress after deleting the old files...oops. Let's try that again..



  • @JaredBusch said:

    @ajstringham does not explain why apache config files are different. one would think that would work the same because it is apache not the OS.

    True.



  • @ajstringham said:

    What I can't figure out is why ThanksAJ.com DOES work but BuiltByArt.com DOES NOT. They are configured exactly the same.

    One is being picked up as the default fall through and the other is not.



  • Hmm....



  • I checked the 000-default.conf file. It's all generic. Nothing set in there. So that's not it.



  • Ubuntu's non-standard Apache config files don't make this any easier either.



  • @scottalanmiller said:

    Ubuntu's non-standard Apache config files don't make this any easier either.

    I need this up and going by tomorrow! Any help is greatly appreciated!



  • @ajstringham I cannot help sorry, I just turned up 4 websites on my CentOS7 server. all working perfectly.



  • @JaredBusch said:

    @ajstringham I cannot help sorry, I just turned up 4 websites on my CentOS7 server. all working perfectly.

    I figured out the issue. I had everything set up correctly. Turns out my NoIP settings were wrong. Once I fixed those (that is what actually fixed it), it all started working! @scottalanmiller helped out tremendously! Thanks all!