Ryzen 7 1700 + GeForce 8400 GS = no display



  • Help me out abit, why Ryzen 7 1700 wont work with GeForce 8400 GS ?

    I bought the cheapest PCI GPU so I can manage and see the whitebox machines, but when I open it nothing is displayed.

    Will use borrowed modern GPU tomorrow.

    No beeps or errors.

    The GeForce 8400 GS

    Works well in an FM2+ Board with Athlon 750k

    I really dont understand why AMD wont do a very small minimal GPU with those CPU, just enough to make you install Linux.

    **UPDATE:

    Turns out to be RAM related. this build is all trouble so far.**

    **UPDATE 2:

    Changing the RAM to different model fixed everything. So it was RAM issue after all.

    The was no beeper. new Motherboards drops this in favor of LED lighting, but at same time this mobo has alot of light and I dont know what is normal what is not, my first thoughts was the GPU.

    For example there is red light near SATA ports, called southbridge power, and yes it is in red. YOu think it is dangerous but it just means chipset is powered, whatever that means.



  • That is what 3 and 5 series are for, people who want igpu.



  • @momurda

    5 series and 3 series does not have iGPU

    Only 2 special models have them.

    But that is not the question, the question is why it didnt work with the old external GPU

    I am closing in to the fast that Ryzen supports GPU PCI 3 and not older. I think, or maybe it is another thing like the RAM.

    Tomorrow will tell.



  • I would guess the motherboard is the problem with your lack of display. Usually bad ram will cause beeping. If there is a pc speaker hooked up and there are no beeps during POST, then that might mean the cpu is bad. Or that POST cant start due to no display adapter.



  • Does the motherboard have on board display? If so, you might need to go to bios and change display order.



  • @emad-r said in Ryzen 7 1700 + GeForce 8400 GS = no display:

    **UPDATE 2:

    Changing the RAM to different model fixed everything. So it was RAM issue after all.

    There we go. That makes more sense.



  • @harry-lui

    It does but only for specific CPU models, I think only 2. The rest is all CPU only, meaning you need discrete GPU to power up the system which is stupid in 2018.



  • @emad-r said in Ryzen 7 1700 + GeForce 8400 GS = no display:

    @harry-lui

    It does but only for specific CPU models, I think only 2. The rest is all CPU only, meaning you need discrete GPU to power up the system which is stupid in 2018.

    That's what Ryzen processors are. CPU only, no GPU. Know your hardware.


Log in to reply