SnipeIT - Connection Refused



  • For some reason I'm unable to get to my snipeit installation.

    Nothing is in the log files.

    Has anyone else had this happen for no apparent reason?



  • Firewalld and SELinux can both cause this type of behavior. As can permissions on the www folder.



  • @coliver said in SnipeIT - Connection Refused:

    Firewalld and SELinux can both cause this type of behavior.

    Out of the blue though?

    No changes have been made to the system, and I was using it just Friday.



  • @dustinb3403 said in SnipeIT - Connection Refused:

    @coliver said in SnipeIT - Connection Refused:

    Firewalld and SELinux can both cause this type of behavior.

    Out of the blue though?

    No changes have been made to the system, and I was using it just Friday.

    Can you curl it from the local prompt?



  • @coliver

    Yeah.



  • I disabled firewalld with no resulting change.

    It's like the services are just stopped, hrm. . .



  • I can ping both to and from the system.



  • @dustinb3403 said in SnipeIT - Connection Refused:

    I can ping both to and from the system.

    Ping via ip and dns?



  • @black3dynamite said in SnipeIT - Connection Refused:

    @dustinb3403 said in SnipeIT - Connection Refused:

    I can ping both to and from the system.

    Ping via ip and dns?

    Yep.



  • Are httpd and mariadb running?



  • @jaredbusch said in SnipeIT - Connection Refused:

    Are httpd and mariadb running?

    httpd isn't.

    WTF. . .



  • OK so why is httpd not starting. . .



  • @dustinb3403 said in SnipeIT - Connection Refused:

    OK so why is httpd not starting. . .

    Have you try investigating the issue with these commands?

    systemctl status httpd
    journalctl -xe


  • I'm looking at the logs, and the only thing of interest is

    [Mon Aug 07 03:14:01.725621 2017] [auth_digest:notice] [pid 920] AH01757: generating secret for digest authentication ...
    [Mon Aug 07 03:14:01.726484 2017] [lbmethod_heartbeat:notice] [pid 920] AH02282: No slotmem from mod_heartmonitor
    [Mon Aug 07 03:14:01.751367 2017] [mpm_prefork:notice] [pid 920] AH00163: Apache/2.4.6 (CentOS) PHP/5.6.30 configured -- resuming normal operations
    [Mon Aug 07 03:14:01.751385 2017] [core:notice] [pid 920] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    [Sun Aug 13 03:32:01.788305 2017] [mpm_prefork:notice] [pid 920] AH00171: Graceful restart requested, doing restart
    [Sun Aug 13 03:32:01.909526 2017] [so:warn] [pid 920] AH01574: module rewrite_module is already loaded, skipping
    AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain. Set the 'ServerName' directive globally to suppress this message


  • The host name is set. . .

    GNU nano 2.3.1                             File: /etc/hosts
    
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    127.0.0.1   localhost.localdomain snipeit.OURDOMAIN.com


  • @dustinb3403 said in SnipeIT - Connection Refused:

    The host name is set. . .

    GNU nano 2.3.1                             File: /etc/hosts
    
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    127.0.0.1   localhost.localdomain snipeit.OURDOMAIN.com
    

    What's up with the duplicate entry for localhost?



  • @black3dynamite said in SnipeIT - Connection Refused:

    @dustinb3403 said in SnipeIT - Connection Refused:

    The host name is set. . .

    GNU nano 2.3.1                             File: /etc/hosts
    
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    127.0.0.1   localhost.localdomain snipeit.OURDOMAIN.com
    

    What's up with the duplicate entry for localhost?

    Ask the co-worker. . . I've cleaned that up so it's just the one. And have just used

    hostnamectl set-hostname to set the name, rebooting



  • @dustinb3403 Might also want to check out your httpd.conf and snipeit.conf file too.



  • @black3dynamite

    [root@snipeit conf.d]# cat snipeit.conf
    ##  Creating the new virtual host in Apache.
    
    
    LoadModule rewrite_module modules/mod_rewrite.so
    
    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    	<Directory /var/www/html/snipeit/public>
    		Allow From All
    		AllowOverride All
    		Options +Indexes
       </Directory>
    	DocumentRoot /var/www/html/snipeit/public
    	ServerName snipeit.domain.com
    		ErrorLog /var/log/httpd/snipeIT.error.log
    		CustomLog /var/log/access.log combined
    </VirtualHost>
    

    And httpd.conf is set to the same fqdn



  • @dustinb3403 said in SnipeIT - Connection Refused:

    @black3dynamite

    [root@snipeit conf.d]# cat snipeit.conf

    Creating the new virtual host in Apache.

    LoadModule rewrite_module modules/mod_rewrite.so

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    <Directory /var/www/html/snipeit/public>
    Allow From All
    AllowOverride All
    Options +Indexes
    </Directory>
    DocumentRoot /var/www/html/snipeit/public
    ServerName snipeit.domain.com
    ErrorLog /var/log/httpd/snipeIT.error.log
    CustomLog /var/log/access.log combined
    </VirtualHost>

    And httpd.conf is set to the same fqdn

    Did the httpd.service startup successfully?



  • @black3dynamite No it failed.

    [root@snipeit ~]# systemctl status httpd
    ā— httpd.service - The Apache HTTP Server
       Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Mon 2017-08-14 16:29:45 EDT; 5min ago
    	 Docs: man:httpd(8)
    		   man:apachectl(8)
      Process: 1326 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
      Process: 896 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
     Main PID: 896 (code=exited, status=1/FAILURE)
    
    Aug 14 16:29:43 snipeit.domain.com systemd[1]: Starting The Apache HTTP Server...
    Aug 14 16:29:45 snipeit.domain.com httpd[896]: [Mon Aug 14 16:29:45.339624 2017] [so:warn] [pid 896] AH01574...ping
    Aug 14 16:29:45 snipeit.domain.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Aug 14 16:29:45 snipeit.domain.com kill[1326]: kill: cannot find process ""
    Aug 14 16:29:45 snipeit.domain.com systemd[1]: httpd.service: control process exited, code=exited status=1
    Aug 14 16:29:45 snipeit.domain.com systemd[1]: Failed to start The Apache HTTP Server.
    Aug 14 16:29:45 snipeit.domain.com systemd[1]: Unit httpd.service entered failed state.
    Aug 14 16:29:45 snipeit.domain.com systemd[1]: httpd.service failed.
    Hint: Some lines were ellipsized, use -l to show in full.


  • But for a different reason this time.



  • -- Unit session-2.scope has begun starting up.
    Aug 14 16:36:17 snipeit.domain.com chronyd[595]: Selected source 96.126.105.86
    Aug 14 16:38:01 snipeit.domain.com polkitd[592]: Registered Authentication Agent for unix-process:2415:51024 (system bus name :1.25 [/usr/bin/
    Aug 14 16:38:01 snipeit.domain.com polkitd[592]: Unregistered Authentication Agent for unix-process:2415:51024 (system bus name :1.25, object
    Aug 14 16:38:13 snipeit.domain.com polkitd[592]: Registered Authentication Agent for unix-process:2422:52180 (system bus name :1.26 [/usr/bin/
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: Starting The Apache HTTP Server...
    -- Subject: Unit httpd.service has begun start-up
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit httpd.service has begun starting up.
    Aug 14 16:38:13 snipeit.domain.com httpd[2428]: [Mon Aug 14 16:38:13.395958 2017] [so:warn] [pid 2428] AH01574: module rewrite_module is alrea
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Aug 14 16:38:13 snipeit.domain.com kill[2429]: kill: cannot find process ""
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: httpd.service: control process exited, code=exited status=1
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: Failed to start The Apache HTTP Server.
    -- Subject: Unit httpd.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit httpd.service has failed.
    --
    -- The result is failed.
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: Unit httpd.service entered failed state.
    Aug 14 16:38:13 snipeit.domain.com systemd[1]: httpd.service failed.
    Aug 14 16:38:13 snipeit.domain.com polkitd[592]: Unregistered Authentication Agent for unix-process:2422:52180 (system bus name :1.26, object


  • I'm kind of stumped as to why this happened. To my knowledge nothing was changed within the org over the weekend, and nothing with this system specifically. . .



  • Hrm, is this a Debian/Ubuntu or RedHat/CentOS/Fedora host? This has happened to me before, but I don't remember what fixed it and all my documentation has been wiped out of existence now.



  • @travisdh1 Centos 7



  • Same issue after a reboot

    Aug 14 16:50:04 snipeit.domain.com systemd[1]: Starting The Apache HTTP Server...
    Aug 14 16:50:06 snipeit.domain.com httpd[903]: [Mon Aug 14 16:50:06.723873 2017] [so:warn] [pid 903] AH01574: module rewrite_module ...kipping
    Aug 14 16:50:06 snipeit.domain.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
    Aug 14 16:50:07 snipeit.domain.com kill[1334]: kill: cannot find process ""
    Aug 14 16:50:07 snipeit.domain.com systemd[1]: httpd.service: control process exited, code=exited status=1
    Aug 14 16:50:07 snipeit.domain.com systemd[1]: Failed to start The Apache HTTP Server.
    Aug 14 16:50:07 snipeit.domain.com systemd[1]: Unit httpd.service entered failed state.
    Aug 14 16:50:07 snipeit.domain.com systemd[1]: httpd.service failed.


  • @dustinb3403 said in SnipeIT - Connection Refused:

    @travisdh1 Centos 7

    Of course, one I don't have conveniently running at the moment šŸ˜ž



  • @travisdh1 said in SnipeIT - Connection Refused:

    @dustinb3403 said in SnipeIT - Connection Refused:

    @travisdh1 Centos 7

    Of course, one I don't have conveniently running at the moment šŸ˜ž

    Well hop to it šŸ™‚ Minimal is only 680 MB



  • @dustinb3403 said in SnipeIT - Connection Refused:

    @travisdh1 said in SnipeIT - Connection Refused:

    @dustinb3403 said in SnipeIT - Connection Refused:

    @travisdh1 Centos 7

    Of course, one I don't have conveniently running at the moment šŸ˜ž

    Well hop to it šŸ™‚ Minimal is only 680 MB

    Yeah, and my home lab will do a netinstall in no time flat once I get around to it.


Log in to reply